読者です 読者をやめる 読者になる 読者になる

MacOSXにoci8とpdo-ociに対応したPHPを入れる

面倒なことに、Mac標準のPHPはpdo-ociに対応していない。 本来はbrewでオプション指定(brew install php53 --with-pdo-oci)で入れればよいはずなのだが、 何故かうまくいかないのでphp-buildを使って対応版を入れる。

MacOSX MavericksにおいてJDK7でEclipseを動かす方法

Mac

MacOSXをMavericksにアップデート後、JDK1.7が入っているにも関わらず、Eclipseが以下のメッセージを出して起動しなくなった。 "Eclipse"を開くには、Java SE 6 ランタイムが必要です。今すぐインストールしますか? 今どきJDK6なんてありえないので、JDK7で…